Power supply not recognized by M-series router

Some power supplies for M7i and M10i might contain an incorrectly programmed I2C ID.
As a result the following errors appear in the show chassis alarms output:

  user@M10i-re0> show chassis alarms 
  2 alarms currently active
  Alarm time               Class  Description
  2006-11-29 16:21:22 GMT  Major  PEM 0 Unrecognized for the platform
  2006-11-29 16:21:22 GMT  Major  PEM 1 Unrecognized for the platform

A fix is provided in JUNOS  8.1R2, 8.2R1 and higher JUNOS releases.

Below there is an example with a step by step procedure:

  • Check which power supplies are not recognized properly:
        root@Junos-re0> show chassis alarms
        2 alarms currently active
        Alarm time               Class  Description
        2006-11-29 16:21:22 GMT  Major  PEM 0 Unrecognized for the platform
        2006-11-29 16:21:22 GMT  Major  PEM 1 Unrecognized for the platform
  • Go to the shell and and use command su to change to super-user:
        root@Junos-re0> start shell 
        % su
        Password:
        root@Junos-re0%
  • Use the smbc command to read out the currently (incorrectly) programmed I2C ID for PSU in slot 0:
        root@Junos-re0% smbc -g 2 -o 5 0x56 1
        Read from bus address 0x56 returns:
        0x06
  • Re-program the I2C ID for the same PSU:
        root@Junos-re0% smbc -w -g 2 -o 5 0x56 0x0E
  • Verify if the the I2C IC has been programmed correctly
        root@Junos-re0% smbc -g 2 -o 5 0x56 1
        Read from bus address 0x56 returns:
        0x0e
  • Repeat the same steps for PSU in slot 1
        root@Junos-re0% smbc -g 3 -o 5 0x56 1
        Read from bus address 0x56 returns:
        0x06
        root@Junos-re0% smbc -w -g 3 -o 5 0x56 0x0E
        root@Junos-re0% smbc -g 3 -o 5 0x56 1
        Read from bus address 0x56 returns:
        0x0e
  • Go back to the shell

root@Junos-re0% exit

Chassisd has to be restarted in order to have the alarms cleared.  Note: This is traffic affecting! :

    root@Junos-re0> restart chassis-control
    Chassis control process started, pid 3553
Verify that no PSU related alarms are active:

    root@Junos-re0> show chassis alarms
    No alarms currently active

Leave a Reply

Your email address will not be published. Required fields are marked *